Project

General

Profile

Bug #199

Keine paypal-Abfrage nach Passwortaktualisierung möglich

Added by rhabacker over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Category:
AqBanking
Start date:
02/18/2020
Due date:
Betriebssystem:
Linux
AqBanking-Version:
6.0.2.0
Anwendung:
aqbanking-cli
Version der Anwendung:
6.0.c248ed3e

Description

Nach einer Passwortaktualisierung eines paypal-Kontos funktionierte die balance Abfrage über aqbanking-cli nicht mehr.

3:2020/02/18 20-57-32:aqbanking-cli(4897):provider_sendcmd.c: 298: Handling user "" ===== Enter Password =====
Please enter the password for
Paypal user

Input: *****
3:2020/02/18 20-57-37:gwen(4897):padd.c: 210: First byte is not a 0x60
accountInfoList {
} #accountInfoList

securityList {
} #securityList

messageList {
} #messageList

So wie ich die Hilfe von aqpaypal-tool verstanden habe, ist die Funktion 'setsecret'
für den Zweck vorgesehen, das Passwort zu aktualisieren.

aqpaypal-tool --help
setsecret:
set credentials for Paypal API

Ruft man diese Funktion auf, erscheint:

aqpaypal-tool setsecret
ERROR: Unknown command "setsecret".
3:2020/02/18 20-50-34:aqpaypal-tool(4708):aqpaypal-tool.c: 246: Error calling control function (1)

Versions:
AqBanking-CLI: 6.0.c248ed3e
Gwenhywfar : 5.1.3.0
AqBanking : 6.0.2.0

Ich konnte mir nur helfen, indem ich ein zusätzliches identisches Konto angelegt habe, dabei das neue Passwort angegeben habe, wodurch ~ überschrieben wurde und das ursprünglliche Konto wieder zugreifbar war.

0001-aqpaypal-tool-Correction-of-the-help-page-regarding-.patch Magnifier (1.08 KB) rhabacker, 04/12/2020 01:47 PM

0001-aqpaypal-tool-5.8-Correction-of-the-help-page-regard.patch Magnifier (1.09 KB) rhabacker, 04/12/2020 01:53 PM

History

#1 Updated by rhabacker over 1 year ago

  • Description updated (diff)

#2 Updated by rhabacker over 1 year ago

  • Anwendung KMyMoney added

Bei diesem Problem führt einen aqpaypal-tool --help in die Irre weil im Code 'setsecrets' erwartet wird.

  else if (strcasecmp(cmd, "setsecrets")==0) {
    rv=APY_Control_SetSecrets(pro, db, argc, argv);
  }

das ist auch schon bei 5.8.0 so.

#3 Updated by rhabacker over 1 year ago

Patch angehängt

#5 Updated by rhabacker over 1 year ago

Auf https://www.aquamaniac.de/rdm/projects/aqbanking/wiki/Paypal_einrichten ist das auch falsch dokumentiert:

In dem Abschnitt "PayPal-API-ID und Passwort setzen" muss die Zeile

Das mit `adduser` gesetzte Passwort kann mit `setsecret` geändert werden:

in

Das mit `adduser` gesetzte Passwort kann mit `setsecrets` geändert werden:

#6 Updated by martin over 1 year ago

  • Status changed from New to Closed

Danke, ist eingebaut.

Also available in: Atom PDF