Project

General

Profile

Bug #227

TLS 1.2, unklares Zertifikatsproblem

Added by AndreasFilsinger 10 months ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Category:
AqBanking
Start date:
11/18/2020
Due date:
Betriebssystem:
Linux
AqBanking-Version:
aqbanking:5.99.35.1 gwenhywfar:4.99.18rc2-1
Anwendung:
aqbanking-cli
Version der Anwendung:

Description

Ich habe seit heute Zertifikats-Probleme und weis nicht weiter, hat jemand eine Idee?

  1. export AQHBCI_LOGLEVEL=debug
  2. export AQBANKING_LOGLEVEL=debug
  3. aqhbci-tool4 getbankinfo -u 1

Connecting to "banking-bw4.s-fints-pt-bw.de"
Connected to "banking-bw4.s-fints-pt-bw.de"
Using GnuTLS default ciphers.
TLS: SSL-Ciphers negotiated: TLS1.2:ECDHE-RSA-AES-256-GCM:AEAD
5:2020/11/18 11-29-25:aqbanking(838):siotlsext.c: 157: Found matching certificate "F8:34:D3:A2:6B:03:0F:F5:07:80:77:1E:7D:CD:92:33" with same status
5:2020/11/18 11-29-25:aqbanking(838):siotlsext.c: 171: Automatically rejecting certificate [F8:34:D3:A2:6B:03:0F:F5:07:80:77:1E:7D:CD:92:33] (-1)
3:2020/11/18 11-29-25:gwen(838):syncio_tls.c: 1400: Peer cert not accepted (-1), aborting
Could not connect to server

-> also irgendwie wird das Zertifikat nicht akzeptiert? Ich versuche es mit OpenSSL

  1. openssl s_client -connect banking-bw4.s-fints-pt-bw.de:443

hier gelingt die VErbindung ohne Murren, das Zertifikat ist:

Certificate Information:
Common Name: banking-bw4.s-fints-pt-bw.de
Subject Alternative Names: banking-bw4.s-fints-pt-bw.de
Organization: Finanz Informatik GmbH & Co. KG
Locality: Frankfurt am Main
State: Hessen
Country: DE
Valid From: October 15, 2020
Valid To: September 30, 2021
Issuer: QuoVadis Global SSL ICA G3, QuoVadis Limited
Serial Number: 5c09c5d575eee575d0f32c99f6d696a45a3db798

-> Was kann ich noch tun?

History

#1 Updated by ipwizard 10 months ago

Ich hatte das Verhalten auch mal und zwar, nachdem ich die Vorlage eines neuen Zertifikates in AqBanking mal negativ beantwortet hatte. Geholfen hat nur die Referenz auf das Zertifikat in AqBanking manuell zu löschen. Martin wollte das mal ändern, ich kann aber derzeit nicht ohne Weiteres sagen, ob das passiert ist. Auf jeden Fall sehen Deine Versionsnummern schon recht alt aus, kann also sein, dass das Verhalten geändert wurde. Hinweis: kann sein, dass ein Update auf eine neue Version Dein Problem nicht direkt behebt, von Vorteil wäre es allerdings allemal.

#2 Updated by AndreasFilsinger 10 months ago

Danke ipwizard, ich habe jetzt neu compiliert auf Versionen:

aqbanking;6.2.5.0stable
gwenhywfar;5.4.1stable-0

und auch das .aqbanking Verzeichnis gelöscht, also alles neu angelegt.

->Danach tritt der Fehler nicht mehr auf!

#3 Updated by AndreasFilsinger 10 months ago

  • Status changed from New to Resolved

#4 Updated by AndreasFilsinger 10 months ago

  • Status changed from Resolved to Closed

close

Also available in: Atom PDF